Mengatasi Error Code ELIFECYCLE di Laravel 5.6 di Ubuntu 16.04 dan 18.04


Sudah dua minggu di kantor, saya menggunakan Ubuntu 18.04 LTS. Saya memasangnya dengan cara fresh install tidak melalui metode do-release-update. Tentu saja beberapa aplikasi harus saya pasang ulang dan konfigurasi ulang. Satu hal kekurangan kalau kita melakukan fresh install adalah ada saja beberapa aplikasi yang terlupa untuk dikonfigurasi akibatnya tidak dapat berjalan dengan sebagain mana mestinya.

Seperti halnya project saya yang menggunakan Laravel. Saya harus menghadapi berbagai macam galat ketika hendak melakukan perintah npm install. Usut punya usut ternyata masalahnya sepele, yakni npm bawaan Ubuntu 18.04 masih menggunakan versi lawas, sedangkan saya menggunakan Laravel versi 5.6 yang membutuhkan npm lebih baru.

Nah, berikut ini cara saya menangani masalah galat tersebut.

Lalu lakukan perintah berikut

Jika sudah sukses akan seperti tangkapan layar di bawah ini:

Ayo Berlangganan!

Dapatkan pemberitahuan artikel-artikel terbaru super cepat, langsung dari surel Anda.
Lebih dari 320 telah berlangganan situsali.com, ayo segera daftarkan surel Anda sekarang juga!



Perhatian!

Demi kenyamanan bersama, sebelum berkomentar, harap gunakan bahasa yang baik dan benar. Juga baca aturan dalam berkomentar. Dilarang berkomentar yang dapat memicu pertengkaran dan menyinggung unsur SARA (Suku, Agama, Ras, dan Antar Golongan).

Leave a Reply